zl程序教程

您现在的位置是:首页 >  其它

当前栏目

1060 Are They Equal (25 分)

25 are equal
2023-09-27 14:26:26 时间

1060 Are They Equal

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×10^​5 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10^100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

代码

刚开始没有考虑到还有前导0的这种情况,导致有三个测试点没过。。。19分
在这里插入图片描述

#include<bits/stdc++.h>

using namespace std;

int n;

void format(string &s) {
	int index = 0;
	if(s.find(".") != string::npos) {
		index = s.find(".");
		s.erase(index,1);
	} else {
		index = s.length();
	}

	s.insert(s.length(),100,'0');
	s = "0." + s.substr(0,n) + "*10^" + to_string(index);
}

int main(){
	string s1,s2;
	
	cin >> n >> s1 >> s2;
	format(s1);
	format(s2);
	
	if(s1 == s2) {
		cout << "YES " << s1;
	} else {
		cout << "NO " << s1 << " " << s2;
	}
	 
	return 0;
}

进行修改考虑前导0情况之后

#include<bits/stdc++.h>

using namespace std;

int n;

void format(string &s) {
	int index = 0;
	if(s.find(".") != string::npos) {
		index = s.find(".");
		s.erase(index,1);
	} else {
		index = s.length();
	}
	
	// 前面有0的情况导致三个测试点没过emmm 
	// 小数点删除之后,全0的情况判断,有一个测试点 比如2 0 0.00 
	int num0 = count(s.begin(),s.end(),'0');
	if(num0 == s.length()) s="0",index=0;
	// 删除前导0,有两个测试点 
	while(s[0]=='0' && s.length()>1){
	  s.erase(s.begin());
	  index--;
	}
	
	s.insert(s.length(),100,'0');
	s = "0." + s.substr(0,n) + "*10^" + to_string(index);
}

int main(){
	string s1,s2;
	
	cin >> n >> s1 >> s2;
	format(s1);
	format(s2);
	
	if(s1 == s2) {
		cout << "YES " << s1;
	} else {
		cout << "NO " << s1 << " " << s2;
	}
	 
	return 0;
}