zl程序教程

您现在的位置是:首页 >  其它

当前栏目

1151LCA in a Binary Tree(最近公共祖先LCA)[通俗易懂]

通俗易懂 in 最近 公共 Tree Binary 祖先
2023-06-13 09:13:02 时间

原题链接

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification: Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification: For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题解 最近公共祖先

#include<bits/stdc++.h>
#define x first
#define y second
#define send string::npos
#define lowbit(x) (x&(-x))
#define left(x) x<<1
#define right(x) x<<1|1
using namespace std;
typedef long long ll;
typedef pair<int,int> PII;
typedef struct Node * pnode;
const int N = 2e5 + 10;
const int M = 3 * N;
const int INF = 0x3f3f3f3f;
const ll LINF = 0x3f3f3f3f3f3f3f3f;
const int Mod = 1e9;
int in[N],pre[N];
map<int,int>mm;
void lca(int a,int b,int l,int r,int ll,int rr){ 
   
    if(l <= r){ 
   
        int key = pre[l];
        int mid = mm[key];
        int lsum = mid - ll;
        int poxa = mm[a],poxb = mm[b];
// cout<<l<<" "<<r<<" "<<ll<<" "<<rr<<" "<<key<<"-"<<lsum<<endl;
        if(a == key)printf("%d is an ancestor of %d.\n",a,b);
        else if(b == key)printf("%d is an ancestor of %d.\n",b,a);
        else if(poxa < mid && poxb > mid || poxa > mid && poxb < mid)printf("LCA of %d and %d is %d.\n",a,b,key);
        else if(poxa < mid && poxb < mid)lca(a,b,l + 1,l + lsum,ll,mid - 1);
        else lca(a,b,l + lsum + 1,r,mid + 1,rr);
    }
}
int main(){ 
   
    int n,m;
    ios::sync_with_stdio(false);
    cin>>n>>m;
    for(int i = 0;i < m;i ++){ 
   
        cin>>in[i];
        mm[in[i]] = i;
    }
    for(int i = 0;i < m;i ++){ 
   
        cin>>pre[i];
    }
    int x,y;
    for(int i = 0;i < n;i ++)
    { 
   
        cin>>x>>y;
        bool flag1 = (mm.find(x) == mm.end() ? false:true);
        bool flag2 = (mm.find(y) == mm.end() ? false:true);
        if(!flag1 && !flag2)printf("ERROR: %d and %d are not found.\n",x,y);
        else if(!flag1)printf("ERROR: %d is not found.\n",x);
        else if(!flag2)printf("ERROR: %d is not found.\n",y);
        else lca(x,y,0,m-1,0,m-1);
    }
    return 0;
}

发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/168772.html原文链接:https://javaforall.cn