zl程序教程

您现在的位置是:首页 >  其它

当前栏目

Ignatius and the Princess III 1028 (母函数)

函数 The and III
2023-09-14 08:57:15 时间


Ignatius and the Princess III


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15971    Accepted Submission(s): 11266



Problem Description


"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"


 



Input


The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.


 



Output


For each test case, you have to output a line contains an integer P which indicate the different equations you have found.


 



Sample Input


4 10 20


 



Sample Output


5 42 627


//母函数公式为:g(x)=(1+x+x^2+x^3+x^4+......)*(1+x^2+x^4+x^6+......)*(1+x^3+x^6+x^9+......)*......


#include<stdio.h>
int a[1010],b[1010];
int main(){
	int n,i,j,k;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<=n;i++)
		{
			a[i]=1;
			b[i]=0;
		}
		for(i=2;i<=n;i++)
		{
			for(j=0;j<=n;j++)
			{
				for(k=0;k+j<=n;k+=i)
				{
					b[k+j]+=a[j];
				}
			}
			for(j=0;j<=n;j++)
			{
				a[j]=b[j];
				b[j]=0;
			}
		}
		printf("%d\n",a[n]);
	}
	return 0;
}



//拓展一下,下面的这个是母函数公式为g(x)=(1+x)(1+x^2)(1+x^3)......(不能保证是否正确,因为没有相应的题)


 


#include<stdio.h>
int a[1010],b[1010];
int main(){
	int n,i,j,k,t;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<=n;i++)
		{
			a[i]=1;
			b[i]=0;
		}
		t=3;
		for(i=3;i<=n;i++)
		{
			for(j=0;j<=t;j++)
			{
				for(k=0;k+j<=n;k+=i)
				{
					b[k+j]+=a[j];
				}
			}
			t+=i;
			for(j=0;j<=n;j++)
			{
				a[j]=b[j];
				b[j]=0;
			}
		}
		printf("%d\n",a[n]);
	}
	return 0;
}