zl程序教程

您现在的位置是:首页 >  其它

当前栏目

杭电ACM2004

杭电
2023-09-27 14:26:30 时间
Problem Description
输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:
90~100为A;
80~89为B;
70~79为C;
60~69为D;
0~59为E;
 

Input
输入数据有多组,每组占一行,由一个整数组成。
 

Output
对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”。
 

Sample Input
  
  
56 67 100 123
 

Sample Output
  
  
E D A Score is error!
 

#include<iostream> 
#include<cmath>
using namespace std;
int main()
{
	double score;
	while (cin>>score)
	{
		if (score > 100 || score < 0)
			cout << "Score is error!" << endl;
		else
		{
			int f = score / 10;
			switch (f)
			{
			case 10:
				cout << "A" << endl;
				break;
			case 9:
				cout << "A" << endl;
				break;
			case 8:
				cout << "B" << endl;
				break;
			case 7:
				cout << "C" << endl;
				break;
			case 6:
				cout << "D" << endl;
				break;
				default:
					cout << "E" << endl;
					break;
			}
		}
	}
	/*int score;
	while (cin>>score)
	{
		if (score >= 90 && score <= 100)
			cout << "A" << endl;
		else if (score >= 80 && score <90)
			cout << "B" << endl;
		else if (score >= 70 && score <80)
			cout << "C" << endl;
		else if (score >= 60 && score <70)
			cout << "D" << endl;
		else if (score >= 0 && score < 60)
			cout << "E" << endl;
		else
			cout << "Score is error!" << endl;
	}*/
	
	return 0;
}