zl程序教程

您现在的位置是:首页 >  其它

当前栏目

HDU 5319(Painter-暴力)

HDU 暴力
2023-09-27 14:25:13 时间

Painter

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1232    Accepted Submission(s): 547


Problem Description
Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.
 

Input
The first line is an integer T describe the number of test cases.
Each test case begins with an integer number n describe the number of rows of the drawing board.
Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.
1<=n<=50
The number of column of the rectangle is also less than 50.
Output
Output an integer as described in the problem description.
 

Output
Output an integer as described in the problem description.
 

Sample Input
2 4 RR.B .RG. .BRR B..R 4 RRBB RGGB BGGR BBRR
 

Sample Output
3 6
 

Author
ZSTU
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:  5405 5404 5403 5402 5401 
 


暴力把2个方向判一遍




#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cctype>
#include<ctime>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define ForD(i,n) for(int i=n;i;i--)
#define RepD(i,n) for(int i=n;i>=0;i--)
#define Forp(x) for(int p=pre[x];p;p=next[p])
#define Forpiter(x) for(int &p=iter[x];p;p=next[p])  
#define Lson (x<<1)
#define Rson ((x<<1)+1)
#define MEM(a) memset(a,0,sizeof(a));
#define MEMI(a) memset(a,127,sizeof(a));
#define MEMi(a) memset(a,128,sizeof(a));
#define INF (2139062143)
#define F (100000007)
#define MAXN (50+10)
typedef long long ll;
ll mul(ll a,ll b){return (a*b)%F;}
ll add(ll a,ll b){return (a+b)%F;}
ll sub(ll a,ll b){return (a-b+llabs(a-b)/F*F+F)%F;}
void upd(ll &a,ll b){a=(a%F+b%F)%F;}
int n,m;
char s[MAXN][MAXN]; 
int main()
{
//	freopen("D.in","r",stdin);
	
	int T;cin>>T;
	while(T--)
	{
		int n;
		scanf("%d\n",&n);
		For(i,n) scanf("%s",s[i]+1);
		m=strlen(s[1]+1);
		int ans=0;
		Fork(k,2,n+m)
		{
			bool flag=0; 
			For(i,n)
			{
				int j=k-i;
				if (j<1||j>m) continue;
				
				if (s[i][j]=='B'||s[i][j]=='G') {
					if (!flag) flag=1,ans++; 
				}
				else flag=0;
			}
		}
		
		For(i,n) For(j,m/2) swap(s[i][j],s[i][m-j+1]);
		
		Fork(k,2,n+m)
		{
			bool flag=0; 
			For(i,n)
			{
				int j=k-i;
				if (j<1||j>m) continue;
				
				if (s[i][j]=='R'||s[i][j]=='G') {
					if (!flag) flag=1,ans++; 
				}
				else flag=0;
			}
		}
		
		
		
		cout<<ans<<endl;
	}
	
	return 0;
}