zl程序教程

您现在的位置是:首页 >  大数据

当前栏目

HDU 1896 Stones (优先队列)

队列队列 HDU 优先
2023-09-27 14:22:23 时间

Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 662    Accepted Submission(s): 391


Problem Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
 

 

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
 

 

Output
Just output one line for one test case, as described in the Description.
 

 

Sample Input
2 2 1 5 2 4 2 1 5 6 6
 

 

Sample Output
11 12
 

 

Author
Sempr|CrazyBird|hust07p43
 

 

Source
 

 

Recommend
lcy
 

看懂题意,模拟即可:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<cstdlib>

using namespace std;

struct node{
    int loc,dis;
    bool operator < (const node &a) const{
        if(a.loc==loc)
            return a.dis<dis;
        return a.loc<loc;
    }
};

int main(){

    //freopen("input.txt","r",stdin);

    priority_queue<node> q;
    int t,n;
    scanf("%d",&t);
    node cur;
    while(t--){
        while(!q.empty())
            q.pop();
        scanf("%d",&n);
        int a,b;
        while(n--){
            scanf("%d%d",&a,&b);
            cur.loc=a;  cur.dis=b;
            q.push(cur);
        }
        int ans=0;
        int cnt=1,tmp=0;
        while(!q.empty()){
            if(cnt&1){  //第奇数个石子还得往前扔
                ans+=q.top().loc-tmp;
                tmp=q.top().loc;
                cur.loc=tmp+q.top().dis;
                cur.dis=q.top().dis;
                q.pop();
                //printf("     **   %d\n",cur.loc);
                q.push(cur);
            }else{
                ans+=q.top().loc-tmp;
                tmp=q.top().loc;
                q.pop();
                //printf("     ##   %d\n",cur.loc);
            }
            cnt++;
            //printf("tmp=%d   ans=%d\n",tmp,ans);
        }
        printf("%d\n",ans);
    }
    return 0;
}