zl程序教程

您现在的位置是:首页 >  其它

当前栏目

1108 Finding Average

average
2023-09-11 14:22:44 时间

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
 

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
 

Sample Input 2:

2
aaa -9999
 

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

 

思路:

  格式化输入,输出

  sscanf() : C 库函数 int sscanf(const char *str, const char *format, ...) 从字符串读取格式化输入。

  sprintf() : C 库函数 int sprintf(char *str, const char *format, ...) 发送格式化输出到 str 所指向的字符串。

  因为这两个库都是C语言里面的,所以对string好像不太好用,写的时候写成char[]来表示string。

Code:

#include <bits/stdc++.h>

using namespace std;

int main() {
    int n;
    cin >> n;
    int count = 0;
    char in[50], out[50];
    double temp, sum = 0.0;
    for (int i = 0; i < n; ++i) {
        scanf("%s", in);
        sscanf(in, "%lf", &temp);
        sprintf(out, "%.2f", temp);
        bool isLegal = false;
        for (int j = 0; j < strlen(in); ++j) {
            if (in[j] != out[j]) {
                isLegal = true;
            }
        }
        if (isLegal || temp > 1000 || temp < -1000) {
            printf("ERROR: %s is not a legal number\n", in);
        } else {
            sum += temp;
            count++;
        }
    }
    if (count == 1)
        printf("The average of 1 number is %.2f", sum);
    else if (count > 1) {
        double average = sum / count;
        printf("The average of %d numbers is %.2f", count, average);
    } else {
        printf("The average of 0 numbers is Undefined");
    }

    return 0;
}

参考: https://www.liuchuo.net/archives/1924

对于这种题一定要认真读题,不要被以前做过的题给绑架了。