zl程序教程

您现在的位置是:首页 >  其他

当前栏目

ACM-ICPC北京赛区2017网络同步赛

同步网络 2017 北京 ACM 赛区 ICPC
2023-09-14 09:11:41 时间

E: Cats and Fish

时间限制:1000ms
单点时限:1000ms
内存限制:256MB

描述

There are many homeless cats in PKU campus. They are all happy because the students in the cat club of PKU take good care of them. Li lei is one of the members of the cat club. He loves those cats very much. Last week, he won a scholarship and he wanted to share his pleasure with cats. So he bought some really tasty fish to feed them, and watched them eating with great pleasure. At the same time, he found an interesting question:

There are m fish and n cats, and it takes ci minutes for the ith cat to eat out one fish. A cat starts to eat another fish (if it can get one) immediately after it has finished one fish. A cat never shares its fish with other cats. When there are not enough fish left, the cat which eats quicker has higher priority to get a fish than the cat which eats slower. All cats start eating at the same time. Li Lei wanted to know, after x minutes, how many fish would be left.

输入

There are no more than 20 test cases.

For each test case:

The first line contains 3 integers: above mentioned m, n and x (0 < m <= 5000, 1 <= n <= 100, 0 <= x <= 1000).

The second line contains n integers c1,c2 … cn,  ci means that it takes the ith cat ci minutes to eat out a fish ( 1<= ci <= 2000).

输出

For each test case, print 2 integers p and q, meaning that there are p complete fish(whole fish) and q incomplete fish left after x minutes.

样例输入
2 1 1
1
8 3 5
1 3 4
4 5 1
5 4 3 2 1
样例输出
1 0
0 1
0 3

暴力模拟下第几分钟第几条鱼的状态就好了

#include <bits/stdc++.h>
using namespace std;
struct Node
{
    int c,s;
} a[105];
int cmp(Node a,Node b)
{
    return a.c<b.c;
}
int main()
{
    ios::sync_with_stdio(false);
    int m,n,x;
    while(cin>>m>>n>>x)
    {
        for(int i=0; i<n; i++)
            cin>>a[i].c,a[i].s=0;
        sort(a,a+n,cmp);
        for(int i=1; i<=x; i++)
        {
            for(int j=0; j<n&&m; j++)
            {
                if(a[j].s==0)
                {
                    a[j].s=a[j].c;
                    m--;
                }
            }
            for(int j=0; j<n; j++)
                if(a[j].s)
                {
                    a[j].s--;
                }
        }
        int f=0;
        for(int j=0; j<n; j++)
                if(a[j].s)
                {
                    f++;
                }
        printf("%d %d\n",m,f);
    }
    return 0;
}

F: Secret Poems

时间限制:1000ms
单点时限:1000ms
内存限制:256MB

描述

The Yongzheng Emperor (13 December 1678 – 8 October 1735), was the fifth emperor of the Qing dynasty of China. He was a very hard-working ruler. He cracked down on corruption and his reign was known for being despotic, efficient, and vigorous.

Yongzheng couldn’t tolerate people saying bad words about Qing or him. So he started a movement called “words prison”. “Words prison” means literary inquisition. In the famous Zhuang Tinglong Case, more than 70 people were executed in three years because of the publication of an unauthorized history of the Ming dynasty.

In short, people under Yongzheng’s reign should be very careful if they wanted to write something. So some poets wrote poems in a very odd way that only people in their friends circle could read. This kind of poems were called secret poems.

A secret poem is a N×N matrix of characters which looks like random and meaning nothing. But if you read the characters in a certain order, you will understand it. The order is shown in figure 1 below:

            figure 1                                                           figure 2

Following the order indicated by arrows, you can get “THISISAVERYGOODPOEMITHINK”, and that can mean something.

But after some time, poets found out that some Yongzheng’s secret agent called “Mr. blood dripping” could read this kind of poems too. That was dangerous. So they introduced a new order of writing poems as shown in figure 2. And they wanted to convert the old poems written in old order as figure1 into the ones in new order. Please help them.

输入

There are no more than 10 test cases.

For each test case:

The first line is an integer N( 1 <= N <= 100), indicating that a poem is a N×N matrix which consist of capital letters.

Then N lines follow, each line is an N letters string. These N lines represent a poem in old order.

输出

For each test case, convert the poem in old order into a poem in new order.

样例输入
5
THSAD 
IIVOP 
SEOOH 
RGETI 
YMINK
2
AB
CD
4
ABCD
EFGH
IJKL
MNOP
样例输出
THISI
POEMS
DNKIA
OIHTV
OGYRE
AB
DC
ABEI
KHLF
NPOC
MJGD

本来以为深搜好写,结果写炸了。还是直接for比较稳

#include <bits/stdc++.h>
using namespace std;
char s[105][105],c[105][105];
string c1,c2;
int n;
void la()
{
    int j=1,now=0,U=1,D=n,L=1,R=n,i=1,N=n*n;
    if(N==1)
    {
        printf("%c\n",c1[0]);
    }
    else
    {
        while(now<N)
        {
            while(j<R&&now<N)
            {
                c[i][j]=c1[now++];
                j++;
            }
            while(i<D&&now<N)
            {
                c[i][j]=c1[now++];
                i++;
            }
            while(j>L&&now<N)
            {
                c[i][j]=c1[now++];
                j--;
            }
            while(i>U&&now<N)
            {
                c[i][j]=c1[now++];
                i--;
            }
            i++;
            j++;
            U++,D--;
            L++,R--;
            if(now==N-1)c[i][j]=c1[now++];
        }
        for(i=1; i<=n; i++)
        {
            printf("%c",c[i][1]);
            for(j=2; j<=n; j++)
                printf("%c",c[i][j]);
            printf("\n");
        }
    }
    return ;
}
int main()
{
    while(cin>>n)
    {
        for(int i=1; i<=n; i++)
            scanf("%s",s[i]+1);
        c1="",c2="";
        for(int i=1; i<=n; i++)
            if(i%2)
            {
                int t=i;
                for(int j=1; j<=i; j++)
                {
                    c1+=s[t--][j];
                }

            }
            else
            {
                int t=1;
                for(int j=i; j>0; j--)
                {
                    c1+=s[t++][j];
                }
            }

        for(int i=1; i<n; i++)
            if(i%2)
            {
                int x=n-i+1,y=n,t=i;
                while(t--)
                {
                    c2+=s[x++][y--];
                }

            }
            else
            {
                int x=n,y=n-i+1,t=i;
                while(t--)
                {
                    c2+=s[x--][y++];
                }
            }
        reverse(c2.begin(),c2.end());
        c1=c1+c2;
        la();
    }
    return 0;
}