zl程序教程

您现在的位置是:首页 >  其它

当前栏目

PAT 1049 Counting Ones[dp][难]

DP PAT Counting
2023-09-14 09:11:24 时间
1049 Counting Ones (30)(30 分)

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=2^30^).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:

12

Sample Output:

5

 题目大意:给出一个数字N,你要找出所有1-N中包含的1的个数。N<=2^30。

 //N还挺大的。猛一看很简答,直接遍历就行,但是数据量太大。如果使用动态规划,化解成子问题,怎么做呢?

 代码来自:https://www.liuchuo.net/archives/2305

我还不太懂,明天再看一遍这数学问题。

#include <iostream>
#include<stdio.h>
using namespace std;
int main() {
    int n, left = 0, right = 0, a = 1, now = 1, ans = 0;
    scanf("%d", &n);
    while(n / a) {
        left = n / (a * 10), now = n / a % 10, right = n % a;
        if(now == 0) ans += left * a;
        else if(now == 1) ans += left * a + right + 1;
        else ans += (left + 1) * a;
        a = a * 10;
    }
    printf("%d", ans);
    return 0;
}