zl程序教程

您现在的位置是:首页 >  其它

当前栏目

poj1363——Rails

Rails
2023-09-14 09:08:58 时间

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track. 

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station. 

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0. 

The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes

#include<stdio.h>
int main()
{
    int input[1005],output[1005],cnt,j,i,n;
    while(scanf("%d",&n),n)                    //输入列车节数
    {
        while(scanf("%d",&output[0]),output[0])
        {
            for(j=1; j<n; j++)
                scanf("%d",&output[j]);       //输入出栈的顺序
            for(cnt=1,j=0,i=0; cnt<=n;)       //cnt表示对进站时列车编号,并在编号完毕后退出
            {
                input[i]=cnt;
                //在编号时,假设遇到相应位置同样的出站编号。进入循环。进站顺序向后。出站顺序向前相应,相应成功继续循环
                while(input[i]==output[j])
                {
                    i--;
                    j++;                      //每当相应成功。位置向后移。看是否还能相应
                    //i==-1时,代表进站的车厢相应到达顶端,之前的车厢一定相应成功,代表从刚进入循环时到这里所经历的车厢可以成功出站
                    if(i==-1)
                        break;
                }
                i++;
                cnt++;
            }
            if(j==n)                          //假设成功出站。那么对于出站列车,每节车厢都相应成功
                printf("Yes\n");
            else
                printf("No\n");
        }
        printf("\n");
    }
}