zl程序教程

您现在的位置是:首页 >  其它

当前栏目

uva 10305

UVa
2023-09-14 09:08:08 时间


/*************************************************************************
     File Name: 10305four.cpp
     Author: yubo
     Mail: yuzibode@126.com 
     Created Time: 2014年06月02日 星期一 00时23分06秒
     学习重点:
reference
John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

Input

The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.

Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input

5 4

1 2

2 3

1 3

1 5

0 0

Sample Output

1 4 2 5 3:
http://sbp810050504.blog.51cto.com/2799422/901022
 ************************************************************************/

#include<cstring>
#include<cstdio>
#include<iostream>
#include<stack>
using namespace std;
#define MAXN 105
//have time according to text to write

struct ArcNode{
	int to;
	struct ArcNode* next;
};
ArcNode* List[MAXN];
int n,m;
int counts[MAXN];
int output[MAXN];
void toposort()
{
stack<int> s;
	memset(output,0,sizeof(output));
	for(int i=0;i<n;i++){
		if(counts[i]==0){

		
			s.push(i);
		}
	}
	bool bcycle=false;
	ArcNode* temp=new ArcNode;
	int k=0;
	for(int i=0;i<n;i++){
		if(s.empty()){
			bcycle=true;
			break;

		}
		else{
			int j=s.top();s.pop();
			output[k++]=j+1;
			temp=List[j];
			while(temp!=NULL){
				int f=temp->to;
				counts[f]--;
				if(counts[f]==0){
					s.push(f);
				}
				temp=temp->next;
			}
		}
	}if(bcycle)
	printf("The Network has a cycle\n");
	else
	{
		for(int l=0;l<n-1;l++)
			printf("%d ",output[l]);
			printf("%d\n",output[n-1]);
	}
}
void del()
{
	ArcNode* temp=new ArcNode;
	for(int i=0;i<n;i++)
	{
		temp=List[i];
		while(temp!=NULL){
			List[i]=temp->next;
			delete temp;
			temp=List[i];
		}

	}

}
int main()
{
	//freopen("in.txt","r",stdin);
	int u,v;
	while(scanf("%d%d",&n,&m)){
		if(!n&&!m)
			break;
		memset(List,0,sizeof(List));
		memset(counts,0,sizeof(counts));
		for(int i=0;i<m;i++){
			scanf("%d%d",&u,&v);
			u--;v--;
			counts[v]++;
			ArcNode* temp=new ArcNode;
			temp->to=v;
			temp->next=NULL;
			if(temp==NULL)
				List[u]=temp;
			else{
				temp->next=List[u];
				List[u]=temp;
			}
		}

		ArcNode* temp=new ArcNode;
		toposort();
		del();
	}
}


版权声明:本文博客原创文章,博客,未经同意,不得转载。