zl程序教程

您现在的位置是:首页 >  其他

当前栏目

PTA 1043 输出PATest (20 分)

2023-04-18 12:41:57 时间

题目

给定一个长度不超过 10 4 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest.... 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。

输入格式: 输入在一行中给出一个长度不超过 10 4 的、仅由英文字母构成的非空字符串。

输出格式: 在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
redlesPayBestPATTopTeePHPereatitAPPT
结尾无空行
输出样例:
PATestPATestPTetPTePePee
结尾无空行

解题思路

inputStr = str(input())
# inputStr = str("redlePayBetPATTopTeePHPereatitAPPT")
strList = ["P","A","T","e","s","t"]
inputStrDic = dict()
## 汇总全部需要的字母的数量
for i in strList:
    inputStrDic[i] = inputStr.count(i)
res = ""
# print(inputStrDic)
while len(inputStrDic) != 0:
    # 逐个字母循环
    for i in strList:
        if i in inputStrDic:
            if inputStrDic[i] == 0:
                del (inputStrDic[i])  # 如果没值了就移除
                continue
            res = res + i
            inputStrDic[i] = inputStrDic[i]-1 #添加字母后数量减1
print(res)